import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-9a-zA-z]{10}\\(\\\\x01[0-9]{1}\\\\x02([0-9]{2})\\\\x02[0-9]{2}\\\\n";
final String string = "\n\n\n\n\n"
+ "4nY6zVk61Z(\\x010\\x0205\\x0202\\n\n"
+ "4nY8GkxuEy(\\x010\\x0201\\x0202\\n\n"
+ "4nYA5W4GtJ(\\x010\\x0205\\x0202\\n\n"
+ "4nY6zVk61Z(\\x010\\x0205\\x0202\\n\n\n"
+ "4nY8spkhEULA1701\\x0276\\x0276\\x011(\\x012(\\n\n"
+ "4nY8spkhEULA1701\\x0276\\x0276\\x011(\\x012(\\n\n\n\n\n\n"
+ "\\x02([0-9]{2})\\x02";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}