use strict;
my $str = '
4nY6zVk61Z(\\x010\\x0205\\x0202\\n
4nY8GkxuEy(\\x010\\x0201\\x0202\\n
4nYA5W4GtJ(\\x010\\x0205\\x0202\\n
4nY6zVk61Z(\\x010\\x0205\\x0202\\n
4nY8spkhEULA1701\\x0276\\x0276\\x011(\\x012(\\n
4nY8spkhEULA1701\\x0276\\x0276\\x011(\\x012(\\n
\\x02([0-9]{2})\\x02';
my $regex = qr/^[0-9a-zA-z]{10}\(\\x01[0-9]{1}\\x02([0-9]{2})\\x02[0-9]{2}\\n/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}