#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)[\(\)]"
Local $sString = "жвадл (ы аы)ыва (dg dg dg (((( sdf (99" & @CRLF & _
"" & @CRLF & _
"жвадл (ы аы)ыва (dg dg dg (((( sdf (99" & @CRLF & _
"" & @CRLF & _
"жвадл (ы аы)ыва (dg dg dg (((( sdf (99" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")