$re = '/[\(\)]/mi';
$str = 'жвадл (ы аы)ыва (dg dg dg (((( sdf (99
жвадл (ы аы)ыва (dg dg dg (((( sdf (99
жвадл (ы аы)ыва (dg dg dg (((( sdf (99
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);