#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Requester\n\n.+\n\n(?<name>.+?)\s\((?<email>[^)\n\r ]+)\)?"
Local $sString = "Requester" & @CRLF & _
"" & @CRLF & _
"jeff@gmail.com" & @CRLF & _
"" & @CRLF & _
"Loren Goodtree (lg@gmail.com)" & @CRLF & _
"" & @CRLF & _
"To view the completed version, please see the file attached." & @CRLF & _
"" & @CRLF & _
"Best," & @CRLF & _
"" & @CRLF & _
"Matt Hernandez" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")