using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)\[([^\[\]]+)";
string input = @"3[a]2[bc]
3[a2[c]]
2[abc]3[cd]ef
abc3[cd]xyz";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}