$re = '/(\d+)\[([^\[\]]+)/m';
$str = '3[a]2[bc]
3[a2[c]]
2[abc]3[cd]ef
abc3[cd]xyz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);