// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d+)\[([^\[\]]+)").unwrap();
let string = "3[a]2[bc]
3[a2[c]]
2[abc]3[cd]ef
abc3[cd]xyz";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}