#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)<!--\s*\*\s*style\s*-->(.+?)<!--\s*/style\s*-->"
Local $sString = "<!-- *style -->" & @CRLF & _
"<style>" & @CRLF & _
" .page {" & @CRLF & _
" display: grid;" & @CRLF & _
" grid-template-columns: repeat(3, 1fr);" & @CRLF & _
" grid-template-rows: repeat(7, 13.468%);" & @CRLF & _
" align-content: end;" & @CRLF & _
" width: var(--w);" & @CRLF & _
" aspect-ratio: 210 / 297; /* A4 portrait */" & @CRLF & _
" }" & @CRLF & _
"</style>" & @CRLF & _
"<!-- /style -->" & @CRLF & _
"<div class="page" style="[style]">\r\n[items]" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
" }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")