$re = '/(?s)<!--\s*\*\s*style\s*-->(.+?)<!--\s*/style\s*-->/m';
$str = '<!-- *style -->
<style>
.page {
display: grid;
grid-template-columns: repeat(3, 1fr);
grid-template-rows: repeat(7, 13.468%);
align-content: end;
width: var(--w);
aspect-ratio: 210 / 297; /* A4 portrait */
}
</style>
<!-- /style -->
<div class="page" style="[style]">\\r\\n[items]
</div>
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);