#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?:\+\(?[0-9]{1,3}|\(?\b[0-9]{4})\)?)?\h*\)?[-\h.]?\(?[0-9]{1,3}\)?[-\h.]?[0-9]{3}[-\h.]?[0-9]{3,4}"
Local $sString = "+1555555555" & @CRLF & _
"+4974339296" & @CRLF & _
"+591 74339296" & @CRLF & _
"+1 555 555 5554" & @CRLF & _
"+(591) 7433433" & @CRLF & _
"+(591) (4) 6434850" & @CRLF & _
"0591 74339296" & @CRLF & _
"0001 5555555555" & @CRLF & _
"(0001) 5555555" & @CRLF & _
"59145678464" & @CRLF & _
"" & @CRLF & _
"3298494333"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")