const regex = /(?:(?:\+\(?[0-9]{1,3}|\(?\b[0-9]{4})\)?)?\h*\)?[-\h.]?\(?[0-9]{1,3}\)?[-\h.]?[0-9]{3}[-\h.]?[0-9]{3,4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:\\+\\(?[0-9]{1,3}|\\(?\\b[0-9]{4})\\)?)?\\h*\\)?[-\\h.]?\\(?[0-9]{1,3}\\)?[-\\h.]?[0-9]{3}[-\\h.]?[0-9]{3,4}', 'gm')
const str = `+1555555555
+4974339296
+591 74339296
+1 555 555 5554
+(591) 7433433
+(591) (4) 6434850
0591 74339296
0001 5555555555
(0001) 5555555
59145678464
3298494333`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}