import Foundation
let pattern = #"(?:(?:\+\(?[0-9]{1,3}|\(?\b[0-9]{4})\)?)?\h*\)?[-\h.]?\(?[0-9]{1,3}\)?[-\h.]?[0-9]{3}[-\h.]?[0-9]{3,4}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
+1555555555
+4974339296
+591 74339296
+1 555 555 5554
+(591) 7433433
+(591) (4) 6434850
0591 74339296
0001 5555555555
(0001) 5555555
59145678464
3298494333
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)