import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^[]+)\\[([^:\\]]+)[^\\]]*\\]([^[]+)\\[\\/\\2\\]";
final String string = "There's a problem with your [anchor:info]Account Details[/anchor].\n"
+ "There's a problem with your [anchor:rewards]Sign Up For Rewards[/anchor].\n"
+ "We didn't recognize this account. Please re-enter your email or [link-to:register]Create An Account[/link-to].";
final String subst = "\\1\\3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}