use strict;
my $str = 'There\'s a problem with your [anchor:info]Account Details[/anchor].
There\'s a problem with your [anchor:rewards]Sign Up For Rewards[/anchor].
We didn\'t recognize this account. Please re-enter your email or [link-to:register]Create An Account[/link-to].';
my $regex = qr/^([^[]+)\[([^:\]]+)[^\]]*\]([^[]+)\[\/\2\]/mp;
my $subst = '\\1\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";