# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([^[]+)\[([^:\]]+)[^\]]*\]([^[]+)\[\/\2\]"
test_str = ("There's a problem with your [anchor:info]Account Details[/anchor].\n"
"There's a problem with your [anchor:rewards]Sign Up For Rewards[/anchor].\n"
"We didn't recognize this account. Please re-enter your email or [link-to:register]Create An Account[/link-to].")
subst = "\\1\\3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.