import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^A(?:(?![A-Z]{2}).)*?\\K\\d+";
final String string = "A bcd 1 should match and capture 1\n"
+ "Abcd1 should match and capture 1\n"
+ "A bcd should not match because there is no number\n"
+ "A BCd 1 should not match because there is a capital C between the A and the number\n"
+ "A bcd 1 EF should match because 1 is before the EF";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}