# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^A(?:(?![A-Z]{2}).)*?\K\d+"
test_str = ("A bcd 1 should match and capture 1\n"
"Abcd1 should match and capture 1\n"
"A bcd should not match because there is no number\n"
"A BCd 1 should not match because there is a capital C between the A and the number\n"
"A bcd 1 EF should match because 1 is before the EF")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.