package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^s3://([^/]+)/(.*?([^/]+))(?:\.json)$`)
var str = `s3://ssdvs/rhrth/fghfh/gnfhnf/fghrh.json`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}