using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Q \d\. .*?(?=\n\nQ \d\.|$)";
string input = @"Q 1. What is your age?
Ans. 15.
Q 2. What is your name?
Ans. My name is Bond.
My full name is James Bond
Q 3. What is your favorite subject?";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}