const regex = /(?<=\d\.\d{5})\d+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\d\\.\\d{5})\\d+', 'g')
const str = `-103.3751447563353`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);