package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)Teacher_name:[\w\s]+,\s*Remarks:[\w\s]+,\s*`)
var str = `Subject_name: English, Teacher_name: John Doe, Remarks: some comment, Overall_marks:87,
Subject_name: Mathematics, Teacher_name: Doe John, Remarks: some comment, Overall_marks:75,
Subject_name: Science, Teacher_name: JD, Remarks: some comment, Overall_marks:80,`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}