re = /Teacher_name:[\w\s]+,\s*Remarks:[\w\s]+,\s*/i
str = 'Subject_name: English, Teacher_name: John Doe, Remarks: some comment, Overall_marks:87,
Subject_name: Mathematics, Teacher_name: Doe John, Remarks: some comment, Overall_marks:75,
Subject_name: Science, Teacher_name: JD, Remarks: some comment, Overall_marks:80,'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result