using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!^)(?=[A-Z][a-z])|(?<=[a-z])(?=[A-Z])";
string substitution = @" ";
string input = @"M&MSAreAGoodSnack";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}