const regex = new RegExp('(?<!^)(?=[A-Z][a-z])|(?<=[a-z])(?=[A-Z])', 'g')
const str = `M&MSAreAGoodSnack`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);