use strict;
my $str = 'M&MSAreAGoodSnack';
my $regex = qr/(?<!^)(?=[A-Z][a-z])|(?<=[a-z])(?=[A-Z])/p;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";