#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^F[A-Z]{0,2}$"
Local $sString = "F" & @CRLF & _
"FA" & @CRLF & _
"FB" & @CRLF & _
"FAA" & @CRLF & _
"FAAA" & @CRLF & _
"BF" & @CRLF & _
"BFA"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")