import re
regex = re.compile(r"(?:(?:\+|00)33|0)\s*[1-9](?:[\s-]\d{2}){4}", flags=re.MULTILINE)
test_str = ("06 66 59 25 28\n"
"0666592528")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")