Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?<=Existing Products & Quantity & ID)(.|\n)*(?=CURRENT)
/
gm
Test String
New
B) For Insert and Modify : Modify Information of Products (Must check and verify) Existing Products & Quantity & ID (1) Jeans 75 J73820 (2) Shirts 10 S02932 (3) Bottoms 2 B0239 *Order ID (Customer Purchase): THK78183XL9102 *Item to check: Stock, Brand *Before and after: CURRENT ----------------------------------------------------------------------------- Product ID : J73820 Quantity : 75 Title : Jeans Brand: XXXX ----------------------------------------------------------------------------- NEXT ACTION Increase stock TO BE ----------------------------------------------------------------------------- Product ID : J73820 Quantity : 100 Title : Jeans Brand: XXXX ----------------------------------------------------------------------------- NEXT ACTION Add 25 unit