$re = '/(?<=[DYM])(?!$)/m';
$str = '1D5Y4D2M';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;