#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(a((?1)|-)b)$"
Local $sString = "a-b" & @CRLF & _
"aa-bb" & @CRLF & _
"aaaa-bbb" & @CRLF & _
"aa-bbbb" & @CRLF & _
"aaaaaa-bbb" & @CRLF & _
"aaaaaaaaaaa-bbbbbbbbbbb" & @CRLF & _
"ab" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")