$re = '/(?sm)^([^,]+?),.+?(?:(\n(?!\1))|\Z)/u';
$str = 'Christi,19946752,20194048
Christi,20369664,20520192
Christi,20520192,20631296
Christi,20123984,20124432
Brandon,20194048,20369664
Brandon,20745984,20980736
Brandon,22341211,22443280
Joe-010,28729383,28733432
Joe-010,23488449,23499482';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);