// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"email.+?\b(\S+@\S+)").unwrap();
let string = "here is some text
that does not hi_there@welcome.co
but this email should be captured yes-well@well.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}