package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(0)[1-9](\d{2}){4}$`)
var str = `0262536900`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}