const regex = /^member_/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^member_', 'gm')
const str = `member_abc123
member_I_am_a_member
not_a_member
never_been_invited_let_alone_an_m_word
member_some_random_group`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}