re = /^(0[1-9]|[12]\d|3[01])(0[1-9]|1[0-2])\d{2}[-]?\d{4}$/m
str = '1610721012
3112121234
011200-1212
011200-1212'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end