// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d+$").unwrap();
let string = "https://www.obi.at/aussenleuchten/aussen-stehleuchten-wegeleuchten/schwarz/f/123456789
https://www.obi.at/987654321
Hausbooot192837465";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}