import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((\\*)(\\/([0-5]?[0-9]))?|(([0-5]?[0-9])(\\/([0-5]?[0-9]))?(-([0-5]?[0-9]))?(,([0-5]?[0-9]))*))$";
final String string = "*\n"
+ "0\n"
+ "1\n"
+ "2\n"
+ "3\n"
+ "4\n"
+ "5\n"
+ "6\n"
+ "7\n"
+ "8\n"
+ "9\n"
+ "10\n"
+ "11\n"
+ "12\n"
+ "13\n"
+ "14\n"
+ "15\n"
+ "16\n"
+ "17\n"
+ "18\n"
+ "19\n"
+ "20\n"
+ "21\n"
+ "22\n"
+ "23\n"
+ "24\n"
+ "25\n"
+ "26\n"
+ "27\n"
+ "28\n"
+ "29\n"
+ "30\n"
+ "31\n"
+ "32\n"
+ "33\n"
+ "34\n"
+ "35\n"
+ "36\n"
+ "37\n"
+ "38\n"
+ "39\n"
+ "40\n"
+ "41\n"
+ "42\n"
+ "43\n"
+ "44\n"
+ "45\n"
+ "46\n"
+ "47\n"
+ "48\n"
+ "49\n"
+ "50\n"
+ "51\n"
+ "52\n"
+ "53\n"
+ "54\n"
+ "55\n"
+ "56\n"
+ "57\n"
+ "58\n"
+ "59\n"
+ "60\n"
+ "61\n"
+ "*/3\n"
+ "*/3/3\n"
+ "62\n"
+ "63\n"
+ "64\n"
+ "65\n"
+ "0/5\n"
+ "0/5/2\n"
+ "14,18\n"
+ "14,18,14,18,14,18\n"
+ "3-39\n"
+ "3-39-50\n"
+ "14,18,3-39,52";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}