#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<!\[CDATA\[(.*)\]\]>"
Local $sString = "<![CDATA[<sender>John Smith</sender>]]>"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)