const regex = /<!\[CDATA\[(.*)\]\]>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<!\\[CDATA\\[(.*)\\]\\]>', '')
const str = `<![CDATA[<sender>John Smith</sender>]]>`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);