re = /<!\[CDATA\[(.*)\]\]>/
str = '<![CDATA[<sender>John Smith</sender>]]>'
subst = '$1'
result = str.sub(re, subst)
# Print the result of the substitution
puts result