using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+ : ""|"",\s*$";
string substitution = @"";
string input = @" ""uid"" : ""Text To Remain"",
""id"" : ""Text2 To Stay"",
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}