$re = '/(?<=_|^)[^_]*2(?=_|$)/';
$str = 'word_word2_word3_word4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);