$re = '/^(?!(\d)(?:-?\1){8})\d{3}(?:-\d\d-|\d\d)\d{4}$/m';
$str = '888888888
123456789
888-88-8888
123-45-6789
111-22-3333
333-33-3333';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);