#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)(\[)(\d+\.\d+\.\d+)(,)(\s)(\d+:\d+:\d+)(])(\s)([^:]+)(:)(.*?)(?=\[\d+\.\d+\.\d+,\s\d+:\d+:\d+]|\Z)"
Local $sString = " [12.06.17, 13:18:36] Name1: Test test test" & @CRLF & _
" [12.06.17, 13:20:20] Name2 ❤️: blabla" & @CRLF & _
" [12.06.17, 13:20:44] Name2 ❤️: words words words" & @CRLF & _
" words" & @CRLF & _
" words" & @CRLF & _
" words" & @CRLF & _
" [12.06.17, 13:29:03] Name1: more words more words" & @CRLF & _
" [12.06.17, 13:38:52] Name3 Surname Nickname: 👍🏼" & @CRLF & _
" [12.06.17, 13:40:37] Name1: message?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")