$re = '/^(0(?:[123]|{.+?})+0)/m';
$str = '01232231{whatever 3 gArBaGe? I want.}121{foo}2310312{bar}3120123
01212121{hello 0}121312
01213123123123{21310030123012301}31231230123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);