$re = '/([\w-]*)\s*:\s*(.*?)(?=\s*(?:;|$))/';
$str = 'min-width:300px;max-width:600px;
overflow-wrap:break-word;
word-wrap
:break-word;word-break:break-word ; margin:
0 auto';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);