const regex = new RegExp('(\\.actionBlock\\[selected\\]\\s*{[^{}]+?color:\\s*)([^;]+)(;)', 'gm')
const str = `.actionBlock[selected] {
color: var(--gray11);
background-color: var(--gray11);
}`;
const subst = `$1#FFF; /* EDITED : $2 */`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);