use strict;
my $str = 'ERROR
we have an ERROR here da da da
ERROR Parent MO not found
ERROR anything else is here
ERROR MO already exists ';
my $regex = qr/ERROR\s+(?!MO already exist).*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}