Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
https:\/\/(youtu.be|www.youtube.com)\/([A-z0-9-_]{11}(\?.*)?$|(watch?.*v=[A-z0-9-_]{11}(\&.*)?$))
/
gm
Input 1
1
New
https://www.youtube.com/watch?v=XNADRNnzP8I https://www.youtube.com/watch?v=z4plxUWOHxw&t=1s https://youtu.be/UW3pBCArsTg https://www.youtube.com/watch?v=4HpjbvLeM3Y&t=124s https://youtu.be/7Jub0c-qQGM https://www.youtube.com/watch?v=vksABX_yYN0&t=1451s https://youtu.be/3dHtbo5wwx4 https://www.youtube.com/watch?v=7QPhMbs2Bd8&t=41s https://www.youtube.com/watch?v=YD2_pXJTcAU https://youtu.be/9bDSzO8wtCA https://www.youtube.com/watch?v=4xfNhseN25E&t=272s https://youtu.be/pKUggMsbQt0?123=asd https://www.youtube.com/watch?v=Vfw8dIp2Oek&t=693s https://www.youtube.com/watch?v=rGYrDPnMCZI https://www.youtube.com/watch?v=Sgy0N8YDYPU&t=13s https://www.youtube.com/watch?v=KmhBN8CpCcc&t=53s https://www.youtube.com/watch?v=dHhyJTSbCbo https://www.youtube.com/watch?v=11pqaRiNyiE&t=325s https://youtu.be/tYWTrORF7QA https://www.youtube.com/watch?v=PQBA2FWST4s&t=7s https://www.youtube.com/watch?v=Av8TwjclvV0&t=1459s https://www.youtube.com/watch?v=0N0vtsHlAr8&t=732s https://www.youtube.com/watch?v=LbLysiDLDYo&t=2347s https://www.youtube.com/watch?v=URuA-IQmvUE&t=111s https://www.youtube.com/watch?v=5kdCFpeC8as&t=532s https://www.youtube.com/watch?v=a5Ck3EZkzMQ https://www.youtube.com/watch?v=Gk0Slcw9IiU&t=78s https://www.youtube.com/watch?v=bFIhb5xhQRM&t=155s https://www.youtube.com/watch?v=37bRMNI4Nv8&t=260s https://www.youtube.com/watch?v=gjC20PWBv8A&t=507s https://www.youtube.com/watch?v=mGrUtnIVoTU&t=7s https://www.youtube.com/watch?v=Tksj76FEWM0&t=208s https://www.youtube.com/watch?v=CM0qCSVqz0U&t=551s https://www.youtube.com/watch?v=NUkSxLq-jRY&t=69s https://www.youtube.com/watch?v=wARglhlugmw&t=52s https://www.youtube.com/watch?v=uVHlgd-ipGc&t=18s https://www.youtube.com/watch?v=rq0JVTztvXQ&t=4s https://www.youtube.com/watch?v=vmE4jQwkbEs&t=420s https://www.youtube.com/watch?v=o_HWltTv950&t=146s https://www.youtube.com/watch?v=4oroFDP4pA0&t=1057s https://youtu.be/fw_RXOylU4c https://www.youtube.com/watch?v=MKg2K3E7azs https://www.youtube.com/watch?v=CetfYpRaJ9c&t=221s https://youtu.be/lkyz58i25Xs https://www.youtube.com/watch?v=W5qkaDDVTOA https://www.youtube.com/watch?v=jycn7qwMVEI https://www.youtube.com/watch?v=cjxe37XrQpI https://youtu.be/MIqi2AgkYt8 https://www.youtube.com/watch?v=-cMOJyhd3BM&t=404s https://www.youtube.com/watch?v=yyU7sm4DlzQ https://youtu.be/uSJWi7a4fcs https://www.youtube.com/watch?v=8ysrYnbEAQw&t=45s https://www.youtube.com/watch?v=NrMoafPlvlg https://youtu.be/uJVAkOwKs1I https://www.youtube.com/watch?v=MqSO4snfEOk&t=98s https://www.youtube.com/watch?v=ekedLxblmS0&t=171s https://www.youtube.com/watch?v=dZ-6WmB8qyA https://youtu.be/20DaWpQqDjM https://www.youtube.com/watch?v=bZuaYnRPa2A https://www.youtube.com/watch?v=Eve6nu2JOq0 https://youtu.be/MpzKeLIoLxk https://www.youtube.com/watch?v=EJVGXBNNp8M&t=713s https://www.youtube.com/watch?v=e1z08cdAdDg https://www.youtube.com/watch?v=k3YTIgyKVOU&t=31s https://youtu.be/d1bDvS6aSVQ https://www.youtube.com/watch?v=owk62eGMGYk https://youtu.be/BLEiCSj5zQ0 https://www.youtube.com/watch?v=g5XdeHy4LEY https://youtu.be/FQ6M2sBmOb0 https://www.youtube.com/watch?v=IS9uOqtvzek https://www.youtube.com/watch?v=YStRsFNgD0o https://youtu.be/lCyZLHqBjrQ https://www.youtube.com/watch?v=WtL1BO8LCoQ https://www.youtube.com/watch?v=T_XTYAULs14 https://www.youtube.com/watch?v=7IP0KEgNwJU https://youtu.be/7_IGRl_FwB8 https://www.youtube.com/watch?v=lamQWEv1wac https://www.youtube.com/watch?v=gi1hJfwCO8Q https://www.youtube.com/watch?v=xixi27wgudI https://www.youtube.com/watch?v=Uq1NcykRak4 https://www.youtube.com/watch?v=ujYzPaf2aKc https://www.youtube.com/watch?v=8NV7kpH9uDE https://www.youtube.com/watch?v=lqvv6zvpMLE https://www.youtube.com/watch?v=ZYqOUdkfWnA https://www.youtube.com/watch?v=dg5fLcelcDI https://www.youtube.com/watch?v=keBU3oaEXBg https://www.youtube.com/watch?v=rV4tzby21x4 https://www.youtube.com/watch?v=tBDtUw0mm3o https://www.youtube.com/watch?v=vlew8sTDxaA https://www.youtube.com/watch?v=eah-0l3oj14 https://www.youtube.com/watch?v=vavpy-tkxEs https://www.youtube.com/watch?v=htmbpUJb9sQ&t=15s https://www.youtube.com/watch?v=MPHKXJdKC7Y&t=50s https://www.youtube.com/watch?v=4VyoXAm2-ls&t=99s https://www.youtube.com/watch?v=O3KK36CTb6Q&t=38s https://www.youtube.com/watch?v=ACQtBkfxAws&t=318s https://www.youtube.com/watch?v=_6bf6yFf720&t=79s https://www.youtube.com/watch?v=Z8NuE57MhIE https://www.youtube.com/watch?v=xAITTZqAwTU https://www.youtube.com/watch?v=Bz3yBhuBtyw&t=51s https://www.youtube.com/watch?v=J7jnUBCoxVk&t=26s https://www.youtube.com/watch?v=DKafoAPOVfE https://www.youtube.com/watch?v=_Wdq0MNCsTw https://www.youtube.com/watch?v=DMJ7AGow2Ms https://www.youtube.com/watch?v=17yMzN4Usp8 https://www.youtube.com/watch?v=a2eobordR8c https://www.youtube.com/watch?v=rkouxiiQWko https://www.youtube.com/watch?v=LErNVYSmmlg https://www.youtube.com/watch?v=tQhT1fQQfCY https://www.youtube.com/watch?v=7blDQn69970 https://www.youtube.com/watch?v=KeOkY7RaZ8E https://www.youtube.com/watch?v=80bEG1-v3Hw https://www.youtube.com/watch?v=xf726v3XRZ8 https://www.youtube.com/watch?v=VRhOgs3fFZk https://www.youtube.com/watch?v=4VyoXAm2-ls&t=101s https://www.youtube.com/watch?v=O3KK36CTb6Q&t=96s https://www.youtube.com/watch?v=N6KMLAftrjk&t=16s https://www.youtube.com/watch?v=rYSmIh5X6iY&t=20s https://www.youtube.com/watch?v=ACQtBkfxAws&t=332s https://www.youtube.com/watch?v=_6bf6yFf720&t=79s https://www.youtube.com/watch?v=Z8NuE57MhIE https://www.youtube.com/watch?v=xAITTZqAwTU https://www.youtube.com/watch?v=Bz3yBhuBtyw&t=51s https://www.youtube.com/watch?v=J7jnUBCoxVk&t=26s https://www.youtube.com/watch?v=SWRasNLVfck https://www.youtube.com/watch?v=DKafoAPOVfE https://www.youtube.com/watch?v=-cMOJyhd3BM&t=404s https://www.youtube.com/watch?v=yyU7sm4DlzQ https://www.youtube.com/watch?v=_Wdq0MNCsTw https://www.youtube.com/watch?v=lh_FKA1c5TM https://www.youtube.com/watch?v=DMJ7AGow2Ms https://www.youtube.com/watch?v=17yMzN4Usp8 https://www.youtube.com/watch?v=TKSU40dCVwQ https://www.youtube.com/watch?v=eMAXGmhFupo&t=1s https://youtu.be/MpzKeLIoLxk https://www.youtube.com/watch?v=EJVGXBNNp8M&t=713s https://www.youtube.com/watch?v=pPq6IkJme0s https://www.youtube.com/watch?v=1cIzQ2xq3Kw https://www.youtube.com/watch?v=heG18vkVJyo&t=32s https://www.youtube.com/watch?v=mVAHph7QpJM https://www.youtube.com/watch?v=FhQ9xSK0oiY https://www.youtube.com/watch?v=Abctipv1Aqk https://www.youtube.com/watch?v=9Kf3EZPUOkk https://www.youtube.com/watch?v=PasZLvRYMR4 https://www.youtube.com/watch?v=keBU3oaEXBg https://www.youtube.com/watch?v=5I1ms4q94uk https://www.youtube.com/watch?v=gwfh4DuS7GQ https://www.youtube.com/watch?v=xxRB6ozPgQM https://www.youtube.com/watch?v=Zq6QfT3017M